« 上一篇 | 下一篇»

moodle 更新到1.9版

04 三月, 2008 13:54 •  (4) 迴響  •  引用(0)  •  3027 hit.  • 分類: moodle   

 圖片來源:moodle官網

華龍數位學習網更新到moodle 1.9版,詳細資料請看這一篇「Moodle 1.9 is now available!」 

新的功能有這些

  • An all-new Gradebook designed from the ground up for expansion and integration with other systems (sponsored by Open University).
  • Integrated support for Outcomes, so that learning goals can be tied to individual courses and activities, and can be graded against (Moodle.com)
  • A huge increase in performance due to review and refactoring of many parts of the Moodle code. Large sites especially will see major speed increases. Special thanks to Catalyst in particular for their scalability work on the core Roles functions. (Catalyst Pty Ltd, Moodle.com etc)
  • Tagging is now a core function allowing us to easily link things like users, blogs, courses etc as well as external sites like Flickr and Youtube through the use of simple tags. (Google SOC and Moodle.com)

moodle要更新,其實很簡單,底下是我的更新步驟:

1.將原本的moodle目錄更名

2.下載moodle1.9,解壓縮後放在網頁根目錄下 

3.用phpMyAdmin將原本的資料庫備份。

4.將原本的moodle裡的config.php複製一份到新的moodle目錄下。 

5.將自己有用到、修改過的 theme、block、mod從舊目錄複製到新目錄。

6.登入moodle,然後就是依照畫面指示,逐一更新,這樣就完成! 

創用 CC 授權條款
 
 
Related Posts Plugin for WordPress, Blogger...

4 Comments on "moodle 更新到1.9版"

 

  1. moodle移機

       作者 lizzie       [管理]

    我的moodle安裝在Fedora上, 最近想要移到另一台Ferora, 我把程式、data、資料庫拷貝過去, 修改config.php, 系統可以run起來, 學生資料及作業都正常, 但我發現電子書及一些線上資源使用的圖片是連到原機器, 為什麼圖片不是相對路徑, 要怎麼處理才可以完整移植?

    那就是這些模組在設計時不是用相對路徑了,它已經把圖片的網址寫進了資料庫。

    所以只能自己手動來修改了。

    我想比較方便的作法,應該是用phpMyAdmin將資料匯出,例如電子書的資料表應該是mdl_book 、mdl_book_chapters 這兩個,把他們匯出,用文字編輯器上的取代功能,將圖片網址改正確後再匯入。

    我只有想到這樣土法煉鋼的方式了。

     

     

  2.  

  3.    作者 nort       [管理]

    請問阿欣老師
    如果moodle使用預設的php mail,而無法發信出去
    那麼應該從哪邊尋找問題呢?
    使用的環境是Centos 4.5


    先檢查是不是沒有安裝sendmail
    可以參考這裡

    阿欣 10:35:16
  4.  

  5.    作者 j       [管理]

    您好

    請問 1.9 版 "上傳中文檔名" 的問題 要如何修正呢?

    我找了1.8、1.6、1.5版的修正方式都不適用

    我的電腦是 win2003 appserv2.9

    想請問您,是否知道修正方法

    謝謝您了

    還沒找到答案耶!暫時還是無法解決。

    你可以考慮一下學學linux吧!這問題就解決啦!微笑

    阿欣 2008/03/19 03:01:41

     

  6.  

  7.    作者 Jack       [管理]

    中文的語系檔,需從1.8移植過來嗎?還是1.9就有新的?

    使用1.8的,我的中文的語系檔一直是放在 moodledata/lang 裡面,所以更新時,並不需要移植。

    官網上的moodle 主程式裡,只有en_utf8,中文語系要到moodle中文加油站去抓會比較完整。

  8.  

發表迴響
 authimage

Google+ 迴響

*********